TBC - Optimizer keeps falling back to original optimizations

Whenever I create a set and press the “re-optimize” button it goes back to default settings.
For example, I’m playing a shadow warlock instead of a fire warlock, even though fire is better.
The reason for this is because we do not have a fire mage in the raid.
I’ve tried to uncheck the Improved Scorch but it still keeps telling me to run Sunfire.
This might be better according to your sims?

I tried to force it into the shadow tree by selecting the Soulfrost enchant on weapon. However, whenever I press the reoptimize it keeps going back to Sunfire.
The same happens for gems. Red gems are very expensive on my realm hence I tend to buy the orange “Veiled Noble Topaz”, so I select these in my gear pieces, however when I run the optimizer again it removes all my previously selected options.

I’m playing a warlock and this is my string:

Quick update, I managed to disable all the other options, except for the gems. I cannot disable the 9 sp one in there.

Leaving my post here in case someone else also runs into this “issue” which can be solved by just disabling everything.

We are looking into why the gem locking is sometimes not working.

With regards to the optimizer picking items with fire spell power: the calculations figure out if shadow bolt or incinerate will do more damage for you, and then assumes you will use the one that does more damage. If you want to be a shadow warlock, take your talent points out of emberstorm and put them into cataclysm - that will make shadow bolt a stronger filler than incinerate and then shadow spell power items will be more valuable.

Good tip! I’ll do that, thanks Swol. Great job getting the addon ready for TBC btw, appreciate the work done.