Time-lost artifact

For the past weeks, AMR tells me to switch one of my trinkets to get the (ilvl 39) Time-lost artifact. How does this even makes sense?

A screenshot doesn’t provide enough information for anyone to properly answer you.
Next press the ** Create support post** button, then copy and paste the string it gives you into a reply.

My guess is that in the setup for Frost BiB you’ve got one set here:
But it’s only a guess as I’ve got no idea what other trinkets you’ve got, I’m expecting them to be on use ones.
The only other thing I can think of is your other trinkets are caster ones.

But without more info you’ve made it very hard to help you solve your dilemma.

First and foremost, thank you for your answer.

Here is, as requested, the string.

Yes, the Max on-use items is set to 1, and I don’t seem to be able to change it. What I did, as an alternate solution, is just to remove the Time-lost artifact from eligible choices and then I get what seems to be a “normal” answer.

Why aren’t you able to change it? You should be able to pick any value in the dropdown list on the Setup step, then press Find Best in Bags to re-optimize. This will also save your setting to the server for the next time you come back to the page.

You ‘can’ set “On use” to no limit, and you get this - it doesn’t appear to be locked from what I can tell:

I’m not sure. It is now stuck at “none”, no matter how many times I click on “no limit”. The same goes with "weapon preference. I set it up to “one-handed” and after I click on Best in Bag, it goes back to "ANY’.

Strange – what browser are you using? And do you have anything disabled/blocked like cookies or local storage?

I tried with Chrome, Firefox, and Edge. It’s not a big deal, as I said I found a way around. I do not have any local storage and my cookies are refreshed regularly.

Thanks for your help anyway, I appreciated it.