Timewalking items not showns as equipped

snapshot ID: b8599a7fedcc4c898d13c05a6e1dc901

Timewarped items are not shown as equipped (with the letter E) even though they are in fact equipped. See screenshot

I have this trouble from time to time generally i re export the string put it again in AMR and get a new import string. Generally it work

@Sienss tried it, doesn’t work for me. Still the same issue

@Swol will take a moment for you i guess because i dont know how to fix this.
You could try : /amr reset
or removed all other addons and retry.

Those two setup are the basic ones i would try.

I’m guessing we must be using a different bonus id for a few of those items than blizzard. We can ask @yellowfive if he can look at this when he has time.

Yeah must be something funky with the timewalking item… they also have a “drop level” that maybe isn’t getting added to the unique item id and isn’t matching up when imported back to the game… would have to play around with some specific examples.

It’s tough to test unless I can get such an item on my own character and go in-game and tinker with the addon code though. I’ll see if I can get one.