Unable to Select Essences

Howdy all, hoping someone has some insight into this problem.

When I’m attempting to select essences (major and minor) on the HoA I just get a blank box.

I use Opera as my browser. It’s worked previously but over the last week it’s been like the above pic. I’ve cleared the cookies and cache in Opera. Also tried on a fresh install of Chrome and Firefox (no addons installed). I’m running a bit short on ideas.

There doesn’t seem to be any other complaints around the internet about it. So unless everyone’s keeping quiet I’m presuming it’s just me.


Weird - can you press the “help” link right above the gear table and use the Create Help Post button to generate a snapshot id - then post that here. We can use that to try your specific setup to see if some combo of setting resulted in a bug.

I think this is on the simulator page – I’ll fix that in the next update.

@Swol - Very weird. I might be blind but I don’t see any help link above the gear table:

Unless I’m looking in the wrong spot? Either way, the essences box is blank for all other characters that I simulate as well. So unlikely that it’s my specific load out.

@yellowfive - Yes I’m on the simulator web page.

Thanks guys!

Both myself and my gf are having the same issues. At least I now know it’s not us messing it up. Any ETA on that update? I am trying to simulate with my essences but of course, have no way to change them in the simulator. Thanks.

Looks like it’s working again. :ok_hand: