Upgrade Finder Bug? - 4/10/21

Snapshot ID: 15761db0d1b6435791825041038c3c25

Yesterday, the upgrade finder seemed to be working fine. Today, if I look at Mythic 10 vault upgrades, everything shows as a downgrade. Even gear I already have equipped that is lower ilvl. I am also not seeing any off hands in the list; not sure if that is related.


Can it be due to you having marked Multi Target strategy instead of single target strategy?

I don’t raid much, just M+, so I always use Multi Target. Still doesn’t make sense going from a 210 ilvl Overwhelming Power Crystal to a 220 would be a DPS loss for example. It was also working fine on Friday.

I’m not sure what’s going on with this upgrade finder result - I’ll have to debug it. If I use “add to my bag” and add the overwhelming power crystal at 220, for example, the optimizer correctly identifies it as an upgrade. For some reason this particular search isn’t working in this case.

I’ll have a fix for this in the next site update (in a day or two) – long story short, it is a very specific issue that happens with dual-wield enchants (mainly just runeforges) when you have the exacting preparation soulbind. It is a rather annoying case to handle behind the scenes, and there was a case where it is getting out of sync.

Thanks for checking into this! I switched covenants last week and probably unlocked the last soulbind slot the day it stopped working. The timing makes more sense now.

I was able to get it updated today – import your character and try the upgrade finder again, it should be fixed now.

Confirmed working, thanks again!

I’m having a similar type issue on a fresh guardian druid. Tried to use upgrade finder and lists every item in the game as a negative increase.

We would need to see your specific case to determine if it is the same as this issue or something else. Follow the instructions here to get us a snapshot: