Upgrade finder error "The optimization took too long"


Snapshot ID above

For both my Hunter and Shaman (shaman above) I am getting the Optimization took too long when I try to check vault or flightstone upgrades.

I have cleaned up bags to remove duplicate items - Explorer versus adventure - etc.
I have cleared the cache in the browser
I have uninstalled/deleted the in game addon
I have rebooted the system
I have opened the bank and bags for minutes to force a re-scan

I think it is something on my end, else more folks would be reporting, but I am stumped at what else to try. Many thanks in advance for any suggestions.

One more note, I was using Chrome, So I tried edge and got the same error.
I also tried on my ipad and got the same error. So it has to be something with the export string.

Same for my Enh shaman, snapshot: 4188eb015fee495cbdfdceab8d18e5a2

EDIT: I can get a result from my second Enh setup which is for Raiding Gearing Strategy. My main setup is Mythic+ gearing strategy which is throwing the “…took too long” error.

I’m also getting “The optimization took too long” error on my shaman when doing Find Upgrades from the vault, catalyst, flightstones/crests and add to bags options. I have two ele, two resto and one enh BIB setups and I got the error for all of them that I tried.

Snapshot id: bbbd0e08f5bb4ac9b7668dd78c8dce33

Same as everyone above. Optimization takes too long for BIB setups and when trying to find an upgrade. I’m also an enhance shaman too. So maybe it a classist thing.

I made some updates to enhancement code that made it more accurate… but apparently too slow. I will work on speeding it up and post a fix today sometime.

1 Like

We just posted an update that should resolve this issue with enhancement shamans taking too long to optimize. If you are still getting an error, please post your snapshot and we’ll take a look and keep refining it.

Success, it works now, thank you all.