Vault upgrade not working?

Hello! I’ve just subscribed to the Premium to get help chosing the vault reward, but it’s still not working.
SnapshotID: 4d022ac6882a456c9ce4226b8578e933

I’ve already open the vault this week, let it open for a few seconds, opened the plugin, got the export string, went over to the site and tried the optimize and it says: " You don’t have any Great Vault rewards available at this time."

Can you help me sort this out?

Maybe because nothing in your vault has value in a certain spec ?
Like intel trinket for a druid feral ?

What items were in your vault? Or, can you give an example of one of them?

Obviously the website doesn’t think it saw anything to export… usually screenshots don’t help much, but in this case maybe posting a screenshot of what you see in your vault could be helpful for us to figure out the issue.

Another thing that could help in this specific case would be the big string of text that you copy from the in-game addon to the website. That can help us narrow down why in this particular case it is not grabbing your vault rewards.