Best in Bags Ignoring Things Randomly in Bank

When doing best in bags it seems to be ignoring some but not all things in the bank. For holy spec for example it’s equipping a 1H str weap (str is missing in AMR tooltip btw for this weap). When clicking in the list for weapons a 291 Int mace is not there, which is in my bank. This also happened for 291 Shock Barrier boots, AMR didn’t pick it nor did I see it in lists as an option until I manually pulled it into my bags from the bank. When changing specs I noticed it was grabbing a few other things from the bank but did not see what they were.

Instance ID: e61907b5a83549efbf02f411ff0591be

We only show the primary stat for your spec on items.

Usually following the steps in this post resolve issues like this, give it a try and let us know if it works:

Did all of the above and still doesn’t think the weapon exists. Snapshot ID 1cb96c21bf494f75a693828e4a1db093 before I cleared everything.

I then cleared cache/data from AMR website. Exited game, cleared AMR variables. Opened game, opened bank, waiting 10-15 second. Switched through all 3 specs and then back to holy. Weapon is still not found in the list to manually pick. Snapshot ID d7345440f27b4a15bb88d89b71ee53c4

Moved weapon to bags. Closed bank and bags. Reopened bank and bags. Waited 10-15 seconds, opened AMR addon, exported and it immediately suggested I use that weapon. Snapshot ID 1421f21114a24157a81ae42efebf9ded

Adding screenshots before and after the last step was taken showing the weapon in the place it was.


The more I’m looking at what is able to be manually picked I think it is ignoring everything in my bank and the only things it pulled before were already in a loadout.

Forgot to get a screenshot but there were very few weapons in my options for Ret when manually selecting on the website. After putting everything in my bags there it looks like all the weapons are in there as they should be. It also is able to pull gear from the bank that is already in a loadout.

Snapshot e428df6f521f44b2829b1a11c1c1c1da

OK I can take a look… it’s possible they changed the bank API with 10.0 and it’s not reading all the bank items.

1 Like

I can’t seem to reproduce this issue in general: I tried deleting my character’s addon data, exported to the website and confirmed there were no bank items, then opened my bank, exported again, and all the bank items showed up.

Just to rule it out, could you try disabling all of your other addons? I wonder if something could be interfering with the bank scanning code somehow…

EDIT: Chain of things done and thoughts
Must be something wrong with my browser? Doesn’t make sense on how that would be interfering with my bank outside of the game. But for science I manually moved entire Addon and WTF folder out of the wow directory and onto my desktop. Downloaded the AMR addon manually and manually installed it into the addons folder. Still the same result.
Snapshot ID 8182936b099f405c9670658909447dcb

Actually, there must be something fundamentally wrong I’m doing. Same result in Firefox, fresh install of it. This is still with the cleaned out addons and only AMR addon installed.
Snapshot ID 432f998bdaff4e5c83699cc65068f489

What might help is if you post the string of data that you are copying from the addon to the website, then I can check it to see if the items are in the export but maybe not showing up on the website for some other reason. Also if you could give me the item name and/or ID of an item or two that should be in your bank/inventory but isn’t showing up on the website with the export that you post. Hopefully that will shed some light on it.

Which browser you use shouldn’t impact this – it all gets sent to the server and processed and saved to your account.

Late start today but still wanted to help with this as much as possible. I happened to noticed that it might only be epic items it’s ignoring in my bags, all blue items in my bank that are eligible for a slot are listed in the choices. Have pastebins of my exports and session IDs for each step. The items I’ve listed below don’t match with what is on wowhead but is as close as I can find, don’t quite understand why but looks like the base IDs for them are the same.

So looking through the options I have on the drop down list and looking what I have in the bank it seems very hit and miss for what is listed for choices on the AMR website. For example, purple helms in the bank don’t show up but purple wrists and rings show up. Think necklace’s too.

Hope I’ve put everything down I’ve thought of. Let me know what else I can do to help.

EDIT: One thing that may not mean anything. After the pre-patch was activated on Tuesday for a day or two my character name and server were listed in my guild roster as my old name and old server. They are fine now, it wasn’t an addon thing, was with the stock interface and others verified.

Two items I moved from bank to bags (before moving these were not in the list, after they are)
Bar-Fusan's Hackblade - Item - World of Warcraft ← this has 2 sockets but mine does not.
Luminous Chevalier's Casque - Item - World of Warcraft ← Ilvl on mine is 246 wowhead has a 244 and 249 listed

Two purple items in bank that aren’t in list
Sorrowbane - Item - World of Warcraft ← has 1 socket, mine does not
Scouring Numerus Crown - Item - World of Warcraft ← mine is 249 ilvl, wowhead has 248

Before moving some items to my bags
da9acc6967b943db8afc53f45a26c2bd
https://pastebin.com/ZcUbgxc5

After moving items
33be732a53134a87bdea5efba25944d9
https://pastebin.com/LRWNSB7b

I can’t get those pastes, they are private.

Don’t worry about ilvl and stuff showing up broken on wowhead, not sure why they always have wacked out item modifications on their pages. When we read your addon data, it also contains the bonus IDs that set items to the correct ilvl, etc.

I was able to grab a last-export from those snapshots, and yeah the first one is missing e.g. that weapon the bar-fusan’s hackblade, and the second one has it. So the addon didn’t see it the first time and it did the second time. The website is reading the data correctly.

Note that inappropriate gear does not show up for a spec, e.g. when looking at Holy we won’t list strength-only weapons in the list.

I can’t really say why only some bank items don’t show up in your data… I can’t reproduce it, and I have no other reports of a similar issue happening to someone else. I have checked and the Blizzard bank API has not changed for in-game addons (probably would see lua errors if it did). I have tried everything I can think with my own characters’ bags and banks, still no problems…

If you modify your bank and/or inventory with the AMR addon window open it’s theoretically possible that the export string won’t update, but if you close the AMR addon window and open it again, it will refresh.

1 Like

Ah never used pastebin before. Apparently the pastes are set as public but “Pending Moderation” status at the moment. Didn’t know that was a thing.

Yeah I have 10 purple 2h str weaps that aren’t showing up when in the bank, wasn’t looking for the off spec weaps in the lists. That and some armor slots have nothing from from the bank, others have everything. Some things only have the blues in the bank.

Just tried again now, opened my bank, waited 10 seconds. Opened AMR addon, exported and then imported to the website. Things missing as above. Pulled everything into my bags, everything shows up fine. Went and sold a bunch of things hoping maybe one of those items was breaking it but no luck. Put all pieces that were not in an armor set into the bank. Closed the bank/bags, waited 10 seconds. Opened the bank and bags, waited 10 seconds and did the export/import again, things were missing as above with some things showing.

Out of curiosity I exported from simc addon to raidbots and there are a LOT of things being read in the wrong slot for that when they are in the bank. When I dragged everything into my bags from the bank, they all showed up properly in the correct slots.

Going to guess or assume something is broken weirdly for my account/character, either that or I’m missing something super obvious. Either way will just hope with updates to the game it’ll fix itself or I’ll randomly fix whatever it is that I theoretically broke. For now I can just drag everything back and forth between the bank/bags and do my gear setup.

That is really strange… so definitely some kind of weird state in the game itself if both addons are reading it incorrectly.

Does this happen only on this character, or all of your characters?

I only have 2 other max level characters and one of them has 7ish purple items. Took them all off and threw them in the bank. So far they seem to show up properly for AMR and raidbots. Will check again in the morning.

oh and the other max level is still sitting in heirlooms and barely has anything else to equip so it’s not a good character to test on. Though it is showing a lot of older armor in lists and that armor is in the bank.

starting to wonder if my main charachter is indeed borked account wise or however the data is stored.

So update on this. A TON of people in my guild have their old server names listed in the guild roster and shown in the guild chat. Going to assume this is why my stuff is broken. I had suspected it before but it had disappeared after a couple of days so put that thought to the side. It’s back now so Blizz needs to fix something.

Had done a server transfer in the past 2-3 months so something is hung up from that and whatever pre-patch changes they have done.

Yeah that’s a weird one – hard for me to even guess what’s happening on Blizzard’s end… hopefully they can sort it out!

Update on this that unfortunately it seems this is still broken for both AMR and SimC exports. While I didn’t get details I have at least one guildie who is having the same issue with things being in the bank. Will possibly open a ticket with Blizz after DF release if it’s still broken but going to assume they’ll auto close it and tell me it’s an addon problem of course.