Best in Bags Issue

Snapshot: fa049c1bec6f43429de29bf1212e74b7
Copy-pasting from the retail version of the game, using best in bags. It seems most of my items are not recognised by the site. Moreover, it shows upgrade options for old items from the bank, such as Gimble and Nithramus, the All-Seer, for rings. Same goes for trinkets, where Frostwolf Insignia seems an option.

The addon will read all of your gear, even things in the bank. When I load that snapshot, it says to keep your current gear equipped.

It appears that you don’t have that many gear options in each slot. If you think that more items should be showing up, sometimes following the steps in this post can clear it up:


I’m experiencing the same issue again.
Just looted Sandals of the West Wind Champion 4/8 - ilvl 424. Didn’t seem to be an upgrade for Best in Bags, so I looked at Upgrade finder.

I then looted Crazed Travelers Legwraps Myth 1/3 ( ilvl 441 ). Copied the addon output, pasted on the website - boom - everything’s out of whack. It doesn’t even show the items as being in my inventory. It even shows

Followed the steps above. Nothing changed.

Weapons options:

It tells me I only have 20 upgradable items, though, by my count, there are 27 items that can still be upgraded with flightstones/crests.

It seems the missing 7 items are

  • 3 legs
    Crazed Traveler’s Legwraps- Champion 2/8 - ilvl 418
    Suffused Leggings - Veteran 3/8 - ilvl 408
    Crazed Traveler’s Legwraps - Myth 1/3 - ilvl 441
  • 2 feet
    Sandals of Ancient Fury - Champion 4/8 - ilvl 424
    ** Sandals of the West Wind - Champion 4/8 - ilvl 424
  • 1 trinket
    Idol of Pure Decay (can’t post a third link, apparently) - Champion 4/8 - ilvl 4/8

All items are in the last bag in my bank (7th bag counting from the left).

Got rid of the duplicate Crazed Traveler’s Legwraps, still no dice.

That’s strange… I ran it through the debugger with the addon import string that we cache that was used to produce your provided snapshot ID. I checked and e.g. Sandals of the West Wind (item ID 133370) simply aren’t in the data. So it’s not an issue with the website/server… the data just isn’t getting picked up by our addon for some reason.

I haven’t run into an issue with some items not getting picked up on any of my characters, and we aren’t seeing any other reports of similar behavior… so it must be something very specific to your case.

You could try moving the items to a different bank bag… see if that makes a difference, though I would be very surprised if it did. That might help narrow it down at least.

This is weird. I just looted Wristwraps of Twined Morels (iLvl 437, Hero 4/5). I checked my bank and I had the same item, but at iLvl 434, Hero 3/5. I opened the addon, copy-pasted and ran a Best in bags search. It turns out that the new loot is not actually an upgrade. But, the thing is: it actually read the new item. And it also saw the item in my bank ( 5th bag, counting from the left). However, it still doesn’t seem to see anything in my last bag (7th from the left).
I’ve got 2 pairs of legs, 3 pairs of feet, 5 rings, 6 trinkets, 2 weapons, 1 offhand, and a bunch of misc items(see the attached screenshot).

None of the items in the 7th bag seem to be available when I select any of the slots on the website to compare with my equipped items.

My other bags are rather full:

Could it be a size limitation on the string the addon generates?

This is the snapshot ID: 12da89e633b7429d8d083e4562e6fdc5

Just looted a Suffed Scepter, it’s in my main bag/backpack - it doesn’t show in the addon.

Snapshot ID: a961efb00e6e4c5aaa243504cce3c4e7

There is no size limitation on the export.

Addon issues are always tough to test because I can’t replicate a user’s case with their inventory in-game.

I just posted an update with v129 of the addon that tweaks a couple things, you can give that a shot and see if it resolves your issue. (It might not be available on curse immediately, but you can always download it directly from Addon).

Not sure what you did, but it seems to have fixed the issue:

Thanks :slight_smile: