"Find Best in Bag" shows me 4 items that are not in my bags (or bank)

Snapshot String

I open my bags & bank, then click the AMR addon ICON , then copy the Export text. I import that in the Wrath AMR page, and when I click to Find Best in Bags, I see 4 items that I’ve never won (note: not in my bags)

Guise of the Midgard Serpent
Chestplate of Vicious Potency
Band of Draconic Guile

I’m using Arkinventory so I can filter my bags by item name as well as search all inventories and can confirm my characters don’t have these 4 items. Feels like I’m just doing something dumb, but not sure what it is.

I can work-around the issue by selecting to exclude those 4 items from optimization, but I’d rather not do that if I can help it.


First give the steps in this post a try:

(It was written for the retail version of the addon, so you can skip step 3, the “activate each spec using the talent UI” part since classic doesn’t have the concept of a spec in-game.)

Let me know if that clears it up, and if not we can try some other things.

I left out that I exited the game, deleted the AMR SavedVariables file for this character, then logged back in. Curious if there was stale / bad info in that file that was causing a hiccup. So I don’t know if that does the same as the steps listed above, but I’ll go through those steps to see if that helps fix it.

thank you for posting the link.

OK, I got it, but it was deleting the SavedVariables file that did the trick. I still had the same issue after trying the steps of opening the bank, waiting a few seconds, then cycling through my Specs.

When I noted I deleted the SavedVariables file previously, I misremembered. What I actually did was told the Overwolf addon manger to “Delete Settings (Saved Variables)”, which did not fix the issue. Tonight I went to the SavedVariables folder itself, for the account, and manually deleted both the lua and lua.bak file.
C:\Program Files\World of Warcraft_classic_\WTF\Account[account]\SavedVariables\AskMrRobotClassic.lua

On the next login, I noticed the export string was noticeably shorter and it no longer contained the extra equipment. I can only imagine the file got contaminated with data from my main, but don’t know why it didn’t reset when I tried the steps listed in your other post.

Either way, I still appreciate your response and figured I would post what cleared it for me.

Glad that worked – theoretically deleting the file shouldn’t be necessary, as the steps above overwrite all saved item data… but there must be another place data is being saved that I missed, I’ll look into that.