In game mr robot failure to open to get string

Mr Robot is failing to open in-game just on my main character. I have uninstalled and reinstalled. When i right click it removes my weapon and a ring. When I left click it prevents me from being able to open my bags and character screen. This does not happen on any other characters… I am at a loss as to what to do next. Have restarted computer and game several times after reinstalling Mr Robot…

Are you getting any lua errors?

An easy way to catch addon errors when you have an issue is to install these two other addons meant for trapping errors:

These are very small addons, the first catches any errors, and the second gives you a minimap button for displaying them.

Could you try installing those addons, then do what is giving you trouble in our addon. If an error happens, copy the error message and paste it here.

3x AskMrRobot\Gear.lua:1171: attempt to index field ‘?’ (a nil value)
AskMrRobot\Gear.lua:1171: in function <AskMrRobot\Gear.lua:1032>
AskMrRobot\Gear.lua:949: in function <AskMrRobot\Gear.lua:912>
AskMrRobot\Gear.lua:975: in function handler' AskMrRobot\Core.lua:661: in function <AskMrRobot\Core.lua:655> [C]: ? ...nts\libs\CallbackHandler-1.0\CallbackHandler-1.0-7.lua:29: in function <...nts\libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:25> ...nts\libs\CallbackHandler-1.0\CallbackHandler-1.0-7.lua:64: in functionFire’
…\AngryAssignments\libs\AceEvent-3.0\AceEvent-3.0-4.lua:120: in function <…\AngryAssignments\libs\AceEvent-3.0\AceEvent-3.0.lua:119>

What specific action causes this error? i.e. what steps would I take in-game to reproduce it?

left clicking on the Mr Robot icon on my mini map causes my keys to lock up for opening character
screen © and bags(B) ((using bagon))Edit to add it locks up my keyboard. No keys work after left clicking the Mr Robot Icon… right clicking the Mr Robot icon swaps out my weapon. It was doing weapon and ring now just does weapon.

Have you tried disabling all other addons to rule out a conflict? Also, have you tried deleting all of the addon settings as well? Using the Twitch App can help with that – otherwise you can manually delete the AskMrRobot.lua and AskMrRobot.lua.bak file found in your WTF folder under your user account folder.

I have not yet started on disabling all of the addons to check if there is a conflict but i did go into my WTF folder/acct name/Character name/SavedVariables and there is no AskMrRobot.lua.bak or lua file even tho the addon is installed. Am I looking in the wrong place?

It would be under your [account name]\SavedVariables folder. We don’t create a separate file for each character, they are all stored in a single file for your user account.

Hi Yellowfive,
I’m back. I have done everything you have previously suggested plus just got to the dreaded disabling of all addons and only loaded AskMrRobot with a fresh reload. Still nothing. Cannot get the string to popup. Works fine still on all my other characters except my hunter. I am at a total loss and rely on this so much for all my armor. Hope you can help me figure out what the issue is. Thanks

In-game addon issues can be tough to troubleshoot because I can’t load your particular character and try it out…

Is there anything unusual about the gear on your hunter?

Usually completely removing all settings and reinstalling the addon should clear up any weirdness due to a bad state being saved… strange that it causes an issue only on that one particular character.

At this point we would need to try and narrow down the issue to something specific that is causing it. Could you post the addon export string that you copy from the in-game addon to the website in order to optimize? Then I could see if there is something unusual on your character.

It’s the export string that won’t open in-game is what my problem is. Opens for all other characters. So what could cause the string to fail to open? If i could get that to open i’d be good… :=) That’s the problem i am having. More troubleshooting… I removed all of my armor, opened askmrrobot addon and still nothing. Did complete shutdown of computer and again still nothing when left clicking on mr robot icon on my minimap. Not sure what else i can check for you.

I am unable to Import the string copied from the AskMrRobot results of Best In Bags.
While i can copy it and place it into the import box… when i click Import nothing happens?
This has been since the 8.2 upgrade to WoW. I was waiting for an update on the App… but so far nothing has helped.

Mine started prior to 8.2. Is it you can’t click in game to get the string to popup? As this is the problem i am having.

Your issue sounds different – could you try installing BugGrabber and BugSack (two small addons that help with trapping addon errors), and see if they capture any errors when you import?

That is strange… it must be having a hard time reading the data for your character… but I haven’t seen reports of that happening to anyone else, so we would need to narrow down what is causing it. Without some kind of error message… we need to come up with another way to figure out what is special about that one character… I’ll give it some thought.

I loaded the Bug Addons and tried again, unfortuantely to no avail… when i copy the string into the import box and hit Import… Nothing happens…
There was no error messages. Very strange

BugSack adds a minimap icon that you can click to see a list of addon errors – sometimes it will catch things and not play a sound or anything. Is there anything at all in the list when you click on it, even from another addon?

Sometimes there are… I just don’t know what to look for in the bugstack to know what is important… Here is the one that is there now. Do you want me to keep sending them here to you to look at?
1x [ADDON_ACTION_BLOCKED] AddOn ‘AAP-Core’ tried to call the protected function ‘EditMacro()’.
!BugGrabber\BugGrabber.lua:519: in function <!BugGrabber\BugGrabber.lua:519>
[C]: in function EditMacro' AAP-Core\QuestHandler.lua:2564: in functionMacroUpdater’
AAP-Core\QuestHandler.lua:965: in function <AAP-Core\QuestHandler.lua:658>
AAP-Core\QuestHandler.lua:4902: in function <AAP-Core\QuestHandler.lua:4826>

It looks like i have25 accumulated do you want me to send them all to you? The one above is just the last one. Some as i recognize them with addon errors i have turned off… not sure of the rest.

You can also clear the error list (if you hover over it tells you the shortcut… either ctrl+click or alt+click the BugSack minimap icon).

Then try opening the window, see if any errors show up in the list.

And yes – it would be helpful to try and disable any addon causing an error, then repeat the issue with the AMR addon causing an error. That helps rule out any possible interaction with another addon, and we can go from there.

If you do get an error from the AMR addon, just copying the whole thing and posting it here is the best thing to do – I believe BugSack has a button to do so… or you might be able to select the whole error and copy it with ctrl+C.

ok i’l look for that… so far i don’t have any bugs with AMR loaded. :=(