Not working. Does not turn on

Clicking left on the minimap button suddenly does nothing. Clicking right gives me the Lua Error below.

Message: Interface\AddOns\AskMrRobot\Gear.lua:1336: attempt to index field '?' (a nil value)
Time: Mon Jul  5 02:20:35 2021
Count: 2
Stack: Interface\AddOns\AskMrRobot\Gear.lua:1336: attempt to index field '?' (a nil value)


What version of the addon are you using? Does this happen on just one character, or all of your characters?

If you type /amr reset in the chat window and press enter, then try to open the addon user interface again by left-clicking the minimap icon, does it show up?

Hello. /amr reset worked for the left click, so I’m able to use the addon. The right click still gives me the error.

I was using the version that was on curse forge when the problem occurred. Then downloaded the 105 version from the website and was still having the same problems.

I didn’t check if the same thing was happening to my other characters before the reset. But the same right click error is still happening on another character.

You should be able to clear up that error by going through the following steps:

First, do the steps in this post:

After doing that, be sure to click the “send to addon” button on the website, and then on the Gear tab of the in-game addon, import your setups. In theory that should reset everything. Let me know if that resolves the issue.

Looks like that worked! The right click doesn’t give me the error anymore. But I also don’t have more than one gear set per spec. Thank you very much!!!