Talents and soulbinds automatically changing

When in a resting area, the talents and soulbinds both revert back to AMR build even after they are manually changed in-game. Is there a way to disable this from happening?

I’m also having this issue, when I try and change my talent it’s being switched back to what Ask Mr Robot has saved. Disabling Ask Mr Robot stops the issue, so I’m confident it’s caused by this addon.

We added a long-requested feature to activate the talents and soulbind that you have specified in your setup on the website when you change setups in-game. It is highly recommended that you play with the same talents/soulbind as you optimized your character, since the optimization is tailored to those talents and soulbind.

But if you don’t like this feature, you can disable it on the options tab of the in-game addon (version 101 or higher).

1 Like

I like that it uses the talents saved, but I was just trying to manually change it myself in a rested area to try something and it was preventing me?

It only changes talents when you press the button (or use a macro) to activate one of your saved setups… otherwise it shouldn’t interact with your talents.

Actually i can confirm it spam change in a rest area for me too. If i change a talent manuall it’s change it back in the second

Strange… doesn’t happen on my characters. I guess I’ll just have to take a stab in the dark at what is causing it for some people…

There might be a little bit of a delay on it… if you wait a couple seconds after activating your setup, are you able to change talents as normal?

I can’t test right now, but it may be something like this or for example if the setup isn’t “complete”, like if i have a missing item or soulbinds that doesn’t perfectly match the exported setup.
That said i tried monday and didn’t retry since, will do later today.

I remember wanted to swap from the exported talent and change using the buff form the Kyrian’s pet to talent that i dont have in any of the spec exported (Healing MM+ nor Raid)

Here is a video I captured of it changing my talents back: https://youtu.be/gXdJAp9RQ6c

I have no other addons enabled.

I have also noticed on the options screen I get a box from the export window on top?

I can confirm it, it’s i was trying to change from Tiger lust to Torpido (mistweaver talent) and even if i wait like 15s it swap back

Try version 102 of the addon, see if that fixes it.

1 Like

I’m still getting the same issues, I noticed I only got the talent swapping issue after I told ask my robot to activate a spec and equip gear.

Yeah sometimes the option window doesn’t repaint… if you drag the addon window to move it a little, it should redraw properly.

I’m not sure why people are getting this issue… I’ll keep trying to reproduce it. For now I’d suggest disabling the feature on the options tab if it is giving you trouble.

I’m not sure if this helps… but when I change a talent it calls onActiveTalentGroupChanged, and then that waits then calls the beginEquipGearSet with true as firstCall, which in turns then runs the setTalents

In this example I have chosen the Born To Be Wild talent, no other actions.


Yeah that should be fine… that should make it try to change your talents just once after a spec change. Works on all my characters… still not able to reproduce the issue that others are seeing.

Is there an option to only have the talents change and NOT the soulbind?

I get the same behavior. If I use the Activate Spec and Equip Gear button and then try to change a talent it will revert the talent back to what is set from the website. If I reload after that, I can then change talents and they stay. The addon then reports “No saved gear set could be found for the current spec”.

Strange… I wonder if the game is somehow queuing up the commands… it’s tough when I can’t reproduce it on my own characters though, still trying to figure out why this happens to certain people.

If you disable the talent-changing feature on the Options tab of the addon though, the issue should go away in the meantime.

If I uncheck Automatically equip gear on spec change, then it stops happening. So I think it has something to do with that option. Maybe that helps narrow it down.