Web Server Upgrade

Our next update will upgrade our servers to improve performance and stability. We are also moving to an all https website. For the most part this will not impact users, but there are a few things that you may notice:

  1. You will have to log in again.

  2. Some saved settings might be reset: your recent character list, the last-run simulation on the simulator page, and for users who are using the site not logged in, your last optimizer settings.

  3. Though not strictly necessary, we recommend that users of our simulator client manually download version 420 or later after the update goes live. The auto-update should still work if you really don’t want to do this, but you will be missing out on a couple of enhancements that can’t be made via an automatic update.

We’re sorry for the inconvenience this will cause, but there is unfortunately no way around it. Please let us know if you need any assistance or run into any issues.


Seems maybe Chrome doesn’t like the upgrade. Still not reading the responses. Works from Edge though.

Could you give some more detail?

One of the servers does seem to be having an issue… working on diagnosing it. But the browser that you use shouldn’t matter.

While using the latest version of chrome, any character load would fail. Armory or addon. I cleared the cache and restarted the browser. No ticket or error code from the site. Jus the “error reading response” I believe was the text. On the same computer using edge all worked fine. I haven’t tried today but had those results Sat and Sun. I will check tonight.

Same today on Chrome. I get the standard Green Legion background with the correct banner but Login fails stating “Error!” under the banner. Trying to load a character brings up an Error dialog box “Could not read response.”

Strange… have you tried clearing your cookies for askmrrobot.com? That might help.

Cleared cookies, restarted browser.
The specified CGI application encountered an error and the server terminated the process.
On login or on basic character loads

That particular bug is an intermittent error I’m working on fixing… haven’t quite figured out the root cause yet. If you wait a few minutes it usually clears up pretty quickly. It is not browser related though, it is a server issue.

Just thought I’d add to this. I use Chrome as well and for a few days now loading the website and the strings is either really slow or it fails.

This is the error I get when it fails:

The specified CGI application encountered an error and the server terminated the process.

Yeah the bug is intermittent… if you try it again a few minutes later it will usually work. Been going at it for a few days trying to find the root cause… still no luck, but hopefully we’re narrowing in on it. I have several people looking into it now.


I am having this kind of problem with latest version of Chrome 62 as well, not possible to log in. Edge works ok.

Have you tried clearing cookies for the askmrrobot.com domain? That usually clears up any issues with logging in after our last server update. You can also try going to the home page and log in from there instead of from another page.

Yes I did all of that, even cleared the other storage the page uses, did not help :frowning: Logging from homepage doesnt help either. Server returns error 400 Bad request:

Request URL:https://www.askmrrobot.com/account/login
Request Method:POST
Status Code:400 Bad Request
Remote Address:

I also did full fresh reload, no cache, tried all can be done from user side / browser side. Please note, as a fellow programmer, I have vast problems with current version of Chrome, as it started to behave weirdly in some areas that used to work till Chrome 61, it might be an issue of browser (when the very same thing works in Edge …)

THe big box talking about the update will not go away and I see no exit,cant use AMR!

What browser are you using? There is a button in the upper right of the window that closes it.

If you have a small screen, the close button might be off-screen… we’ll work on improving that. Use your browser’s zoom feature to zoom out, that should get around it for now.

Are you going to fix the Chrome error? still cannot log in, still Error 400 msg …

I use chrome and have no problems with the site, so it must be something specific to your system…

Latest version 62 of chrome?

Yes, we always use the latest version of chrome for both personal use and testing of the website.